PDA

View Full Version : Question Configuration (Clockwheel)



GecKoTDF
02-06-2011, 08:03 PM
Hi people, whell i have got configured my Clockwhell in this way

Do not play same album within 120 minutes
Do not play same artist within 120 minutes
Do not play same title within 120 minutes
Do not play same track within 120 minutes

The little problem is this (look attachment)... when load the program block do it right, but sometimes at the end start to happend this

Start to repeat some songs (not always the same), in the pal script I configured in this way

Cat['Rock Nacional'].QueueBottom(smLemmingLogic, EnforceRules);

The question is, it's a problem of the Clockwheel configuration, the Pal script or i need more song in the category ? :)

Thank you very much.

SpazzRadio
02-06-2011, 08:38 PM
How many songs are in the category now?

GecKoTDF
02-06-2011, 08:46 PM
I have 186 songs (12:30 hs) have got some repeat artists, and the program block have duration 3 hours.

Ohh well i see the problem now you ask, have got same artist a lot of times... diferent songs but same artist, may be i can, only load a part of the songs in the queue and a few minutes / hours later the another part to complete the program block now, actually when the PAL starts load ALL the music. or just reduce the rule of artist to 60 minutes, what do you think ?

SpazzRadio
02-06-2011, 08:54 PM
that might work.

you could also add more artists to the mix to avoid the problem.

Another option is to lower your clockwheel rules to 60-90 minutes.

Personally I would not use the lemming logic in your song selection. The lemming logic has a tendency to get stuck in a rut/pattern. Try using Random or LRP and see how that goes.

GecKoTDF
02-06-2011, 08:57 PM
Great, yes with the time i will add more artist.

Emm 60 or 90 minutes, what rules ? all or just the Artists rule ?

Ok I will try with Random o LRP (i will read the Wiki about that) and test it.

SpazzRadio
02-06-2011, 09:05 PM
well, just the artist and album rules are really necessary (unless you have some specific need). The title and track are basically redundant if you have artist and album set.

Think about this ... if it can't play the same artist within 90 minutes, then how could it play the same track with the same time.

The title is a little different, but There is generally not an issue if 2 songs with the same title but different artists play close to each other.

So yeah, just change the artist and album rules lower and you can lower the other 2 the same of simply lower them to 1 since they are not necessary.

GecKoTDF
02-06-2011, 09:17 PM
Great :) thank you Spazz, i will try that, and change the Lemming logic in the tracks.

GecKoTDF
02-06-2011, 11:22 PM
Well i make some tests, i use 90 minutes in all Clockwheel rules (really i only have artist an title tag in music), and change the PAL in the part of song selection the Lemming Logic, to smLRP.
Then run the PAL script and start to look and check when start to fail, and i found the problem i test with another category with 66 songs, when load 55 songs start to repeat a song all the time to the end of the PAL.
To solve this problem, y just load 10 o 15 songs and then say the PAL wait 15 minutes and load a second part of tracks, in this way i give the time to "liberate" the old songs from the 90 minutes rules
Now no problem, it's a secure way to get a good rotation of your music with the smLRP if you have a long time block and only a few tracks and some day when i get more music, probably eliminate this "Load stop" but this is a simple way to solve this "repeat" problem.

SOLVED

GKIye
02-07-2011, 01:49 AM
First of all I should "reduce" the album setting (example = within 15 minutes)

If you have only 180+ songs into your playlist, be sure that's "almost nothing"
In other words :
- Its my knowledge that SAM "starts" to work fine with any clockwheel once you reach 2000+ songs and higher
- For reason that your settings are all made to 120 minutes, it is possible that SAM don't find any particular who can be played ... at that moment SAM gonna choose a random song to place it into the queue playlist
- If all 180+ songs are from a "different" artist you can manage to start playing with the amount of minutes
example = artist : 650 | title : 450 | track : 660 minutes
That way you can be "almost" sure that all songs gonna be played

so decrease your album settings and increase the other settings

My 2 cents of knowledge :rolleyes:



Do not play same album within 120 minutes
Do not play same artist within 120 minutes
Do not play same title within 120 minutes
Do not play same track within 120 minutes
.

GecKoTDF
02-07-2011, 01:55 AM
Great, well i left in this way now

Do not play same album within 15 minutes
Do not play same artist within 90 minutes
Do not play same title within 90 minutes
Do not play same track within 90 minutes

And use smLRP to select the songs, Well actually i don't have album tag information in the Tracks so probably the rule of album time not work.
I only detect this problem when i say Sam load a lot of track without stop (a big program block) when i make little program blocks or with time intervals no problem.

GKIye
02-07-2011, 02:00 AM
aaaaaah ... the TAGS
Those are most important to SAM

See it this way : If you don't have the right tags ... its just like SAM is blind, it can't read and don't receive any details
So to SAM all songs are "looking" as the same
That cuts the way SAM "can" choose yes or no a song

Secondly :

I only detect this problem when i say Sam load a lot of track without stop (a big program block)
at the moment SAM loads "tons" of songs into the queue list, that's "the" reason to adjust your settings, both your config and your tag settings
SAM loads only "tons" of songs for reason that SAM "can not" find any "new" who is not yet played song
You can solve this by de-activating the "cache" setting into the same config window

GKIye
02-07-2011, 02:16 AM
PS :

about the caché queue settings ... see the attached PNG image

GecKoTDF
02-07-2011, 02:21 AM
Ahhh yes the tag, i know about it ^^ but i never think about the use of that cache, now i understand the function, well i will make more test with this new information and ideas, and i comment about the results

Thanks GKRadio :D

GKIye
02-07-2011, 02:24 AM
Your welcome ;) (Y)

GecKoTDF
02-07-2011, 03:04 AM
Well i Finish the test, i leave this setting and pal configuration and work OK all the programs block

Do not play same album within 15 minutes
Do not play same artist within 90 minutes
Do not play same title within 90 minutes
Do not play same track within 90 minutes

Then i desactive the Cache option in thw ClockWheel configuration

Leave in the PAL script Lemming logic selection but not load all the music at the same time, load a part... one hour later the another part and in this way i not have any problem :)

Thank you GKRadio and SpazzRadio for the help.