Results 1 to 8 of 8
  1. #1
    shoutcaststreaming's Avatar
    Title
    Premium Member
    Join Date
    Sep 2008
    Location
    Los Angeles, California
    Posts
    784
    Rep Power
    28

    Turn Off SHOUTcast v2 Now Playing History

    Trying to suppress things other than Songs from appearing in the SHOUTcast v2 history. Unlike v1, it appears that I can't do this.

    I have a PAL script that sends out (or suppresses) information on every song change. It works with v1 but not v2. Looks like I can't turn off the automatic Now Playing information after every song change. Version 2 does it automatically.

    Anybody have a work-around ?

    This works in v1 but not v2.

    Code:
    PAL.Loop := True;var Song : TSongInfo;
    var myCurrentSong : TSongInfo;
    
    PAL.WaitForTime(T['+00:00:05']);
    
    myCurrentSong := ActivePlayer.GetSongInfo;
    
    If (myCurrentSong['songtype'] = 'S') then
    
    begin
        writeln('song type = ' + myCurrentSong['songtype']);
        Song := TSongInfo.Create;
        Song['nowplaying'] := myCurrentSong['combine'];
        Encoders.SongChange(Song);
        PAL.WaitForPlayCount(1);
    end;
    SCS - Dedicated Bandwidth Servers
    Shoutcast / Icecast / Windows Media
    Transcoding - Auto DJ - Mobile Radio - FLASH Players - Auto DJ
    Broadcasting World's Stream Host of the Month

  2. #2

    Title
    Junior Broadcaster
    Join Date
    Jul 2014
    Location
    UK
    Posts
    35
    Rep Power
    6
    I'm not quite following what information you're actually trying to filter out as the DNAS (v1 or v2) will just use what is provided from the source software / manual update requests (i.e. via the updinfo handling). So there's nothing really different about v2 other than it can also accept metadata updates in XML.

    If you're just trying to prevent things from appearing on the status pages then setting songhistory=0 should do it (or you can go one step further and just block access to the public stats pages if needed).

    Maybe I'm missing what you're actually wanting to achieve (not having had to mess around with PAL scripts) but it could even be something as simple as missing off a sid=# parameter on whatever the PAL script is trying to do which could be causing things not to work (as sadly there's a few cases where the v2 DNAS needs a sid=# parameter to act like the v1 DNAS due to missing a few compatibility requirements to mirror the v1 DNAS 100%).

    -dro

  3. #3
    shoutcaststreaming's Avatar
    Title
    Premium Member
    Join Date
    Sep 2008
    Location
    Los Angeles, California
    Posts
    784
    Rep Power
    28
    Thank you for answering Dr O.

    That prevented the history from appearing on the DNA page, which isn't what I needed.

    What the script does is it checks to see if what's playing is a song, commercial, station ID, etc. If what's playing is a song (type='S') then it sends the infomation to the DNA's (Artist - Title). If what's playing is a non-song then it doesn't send anything to the DNA's, and ergo, the commercial doesn't appear listed in the History.

    If works perfectly in v1 but does not work in v2. Everything that plays, no matter what, is listed in the History. Just trying to screen out non-songs from being listed. See screenshot. The Bud Light commercial appears, even though I didn't send the info to the DNA's.

    http://prntscr.com/duh8a1
    SCS - Dedicated Bandwidth Servers
    Shoutcast / Icecast / Windows Media
    Transcoding - Auto DJ - Mobile Radio - FLASH Players - Auto DJ
    Broadcasting World's Stream Host of the Month

  4. #4

    Title
    Junior Broadcaster
    Join Date
    Jul 2014
    Location
    UK
    Posts
    35
    Rep Power
    6
    Tbh it sounds more like a problem with the script method you're trying to use rather than the DNAS itself.

    Have you tried having SAM connect to the v2 DNAS in v1 mode to see if it still happens ?

    As my initial thought (now I get what you're wanting) is that that script just isn't being triggered in v2 source mode (as I'm assuming you've setup SAM to connect in v2 mode though v1 mode should work fine).

    -dro

  5. #5
    shoutcaststreaming's Avatar
    Title
    Premium Member
    Join Date
    Sep 2008
    Location
    Los Angeles, California
    Posts
    784
    Rep Power
    28
    I tried that .. I made SAM's encoder think it was a V1 stream. Now I'm getting a double entry:
    http://prntscr.com/dux9wb
    SCS - Dedicated Bandwidth Servers
    Shoutcast / Icecast / Windows Media
    Transcoding - Auto DJ - Mobile Radio - FLASH Players - Auto DJ
    Broadcasting World's Stream Host of the Month

  6. #6

    Title
    Junior Broadcaster
    Join Date
    Jul 2014
    Location
    UK
    Posts
    35
    Rep Power
    6
    Alas I'm out of obvious ideas then (unless anything comes to mind whilst I'm typing this) as I never came across anything like this when I was working on the v2 DNAS unless it was some sort of hack that was present in the v1 DNAS that was never formally documented (which would explain why v2 isn't doing it if that is the case).


    Re-looking at the script and the screenshot, the 'empty title' is the output seen for intended override yes? (I somewhat regret adding that page output it in but with some dodgy encoders that people were using it was needed to show that some sort of title update response had been seen)

    So if that's what the v2 DNAS is showing, have you considered to try having the script just not send out anything for the unwanted title update (assuming that can be done) ?

    -dro

  7. #7
    shoutcaststreaming's Avatar
    Title
    Premium Member
    Join Date
    Sep 2008
    Location
    Los Angeles, California
    Posts
    784
    Rep Power
    28
    To show you the difference, I set up 2 encoders, both playing the exact same songs. The script is running for both.

    Here is the output for the V1 SHOUTcast stream:
    http://prntscr.com/dveug6

    and the output for the V2 SHOUTcast stream:
    http://prntscr.com/dveuql

    You can see that the Station ID's are surpressed in the V1 history, but for V2, it displays the Empty Title. So, something has changed from V1 to V2. Anything else that I should try ? I appreciate your help, Dr O.
    SCS - Dedicated Bandwidth Servers
    Shoutcast / Icecast / Windows Media
    Transcoding - Auto DJ - Mobile Radio - FLASH Players - Auto DJ
    Broadcasting World's Stream Host of the Month

  8. #8

    Title
    Junior Broadcaster
    Join Date
    Jul 2014
    Location
    UK
    Posts
    35
    Rep Power
    6
    Hmm, those screenshots in your newest reply aren't showing the same page so it's hard to compare (v1 summary page, v2 history page).

    The only real option is trying to get SHOUTcast to directly investigate the issue and tweak the DNAS to not show the 'empty title' output (which as I said earlier was added in based on other people's feedback requests). It should be a simple change in the DNAS (either to just strip it out or make it into a configurable behaviour) but you've then got the issue of getting official help.

    As I suppose the offending code page output code could be patched out but that's only a temporary fix. Were you able to get the PAL script to just not send anything on title filtering for v2 ?

    -dro

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •