Results 1 to 2 of 2
  1. #1

    Title
    Junior Broadcaster
    Join Date
    Feb 2021
    Posts
    1
    Rep Power
    0

    Question IceCast don't relay / work anymore; no idea why...

    Hello everyone,I've been running an IceCast on a Windows server for years. Was actually always completely painless, until about 2-6 weeks ago (I can't figure out exactly, since how)Four relay streams of my favorites are set and two DJ mounts, which fall back to stream 2 and 4 when not in use.Recently, when I try to listen to a stream with any client, I get the following message in the IceCast log:
    Code:
    [2021-02-04 23:21:07] WARN slave / slave.c Failed to connect to http://stream.dancewave.online:8080[2021-02-04 23:21:07] WARN slave / slave.c Failed to connect to http://fr4.1mix.co.uk:8060[2021-02-04 23:21:07] WARN slave / slave.c Failed to connect to http://fr4.1mix.co.uk:8000[2021-02-04 23:21:07] WARN slave / slave.c Failed to connect to http://stream.dancewave.online:8080
    A common master that is to be relayed is configured according to the following scheme:
    Code:
        <relay>        <server> http://fr4.1mix.co.uk </server>        <port> 8060 </port>        <mount> / 128h </mount>        <local-mount> / stream1 </local-mount>        <on-demand> 1 </on-demand>        <relay-shoutcast-metadata> 1 </relay-shoutcast-metadata>    </relay>
    The client connects to the server and requests the corresponding relay mount (OnDemand = 1). But then the connection to the respective master fails. The relayed streams themselves work perfectly and can also be called up on the server without any problems (e.g. http://fr4.1mix.co.uk:8060/128h).Just for fun I installed RocketStreamingAudioServer with exactly the same URL's as the master server. it works completely painlessly, with or without SSL. But with IceCast this no longer works recently (same ports with IceCast and RSAS, firewall configured accordingly, of course). What irritates me about it is that it just stopped working without any changes. So I would instinctively assume that the problem is not IceCast, but the Windows server itself (Server 2016 Datacenter, Build 14393.rs1_release.210207-1130), which after an update or similar now shows incompatibilities with IceCast
    Does anyone have a glorious idea?



    Greetz from germany
    Micha

  2. #2
    GKIye's Avatar
    Title
    Moderator
    Join Date
    Nov 2008
    Location
    @ home
    Posts
    3,032
    Rep Power
    71
    Hi Micha,
    First of all ... Welcome to BW.
    Honestly I'm not an IceCast user, I'm using Shoutcast.
    It looks that Your problem is solved ... well I suppose for reason that I hear audio at both http://stream.dancewave.online:8080 and http://fr4.1mix.co.uk:8060

    I'm using 2 Windows10 PCs (a HP & an ACER).
    I was a kind of addict to the Win7 editions, but anyhow I migrated to Win10 and had also several conflicts with typical audio software.
    I'm using ProppFrexx (license) and that works fine.
    However some of my older audio editing softwares created issues. After some updates made by Win10 suddenly a plugin was gone, or the input channel was changed to an other channel etc ...
    Small things who make people on the edge of becoming nuts.

    My proposal would be ...
    If You didn't had any problems before a particular update, reset Your pc to period of time and / or delete the update who created the conflict.
    I'm not a tech guy but thats what I'm trying to do if I experience unexpected problems.

    Good luck !
    Visit and listen @ BW !



Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •