Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    icyshout's Avatar
    Title
    Member
    Join Date
    Jul 2009
    Posts
    40
    Rep Power
    10

    Icecast XSPF playlist

    Has anyone had any problems with icecast not generating the xspf playlist. I have looked and looked and cant find any info related to my specific problem.

    Just a note its not a problem with my server not having the xspf.xsl file.

  2. #2
    saint's Avatar
    Title
    Content Manager
    Join Date
    Mar 2009
    Posts
    1,190
    Rep Power
    28
    What operating system are you using ?

  3. #3
    icyshout's Avatar
    Title
    Member
    Join Date
    Jul 2009
    Posts
    40
    Rep Power
    10
    linux more specifically centos 5.3

  4. #4
    saint's Avatar
    Title
    Content Manager
    Join Date
    Mar 2009
    Posts
    1,190
    Rep Power
    28
    There is a bug in the Debian package that breaks dynamic xspf file generation

    I know your using centos - but you might take a look at the debian bug and see if its related.


    Subject: icecast2: xspf.xsl missing - breaks dynamic xspf generation
    Package: icecast2
    Version: 2.3.2-2
    Severity: important
    Tags: patch

    As I discovered today the debian package is missing the xspf.xsl file in the admin directory (/etc/icecast2/admin/). This breaks the functionality of generating a xspf-playlist for every active mountpoint on the fly.

    http://osdir.com/ml/debian-bugs-clos.../msg03647.html

  5. #5
    icyshout's Avatar
    Title
    Member
    Join Date
    Jul 2009
    Posts
    40
    Rep Power
    10
    yeah the general release is missing the xsl file but you can get it from the trunk i had already seen that issue and got that fixed

  6. #6
    saint's Avatar
    Title
    Content Manager
    Join Date
    Mar 2009
    Posts
    1,190
    Rep Power
    28
    Very Strange ...

    Could it be a issue with Centos ?

  7. #7
    icyshout's Avatar
    Title
    Member
    Join Date
    Jul 2009
    Posts
    40
    Rep Power
    10
    i doubt it. I think it has something to do with my configuration

  8. #8
    saint's Avatar
    Title
    Content Manager
    Join Date
    Mar 2009
    Posts
    1,190
    Rep Power
    28
    What about the mount point configuration ?

  9. #9
    kwdservices's Avatar
    Title
    Senior Member
    Join Date
    Oct 2008
    Posts
    282
    Rep Power
    11
    Yeah we had some issues too, had to download the latest one from Icecast. The old one started making the navigation disappear and wouldn't show listener IP addresses and player clients all of a sudden. Everything has been fine since the upgrade.

  10. #10
    icyshout's Avatar
    Title
    Member
    Join Date
    Jul 2009
    Posts
    40
    Rep Power
    10
    yeah i actually upgraded to the trunk version nightly snapshot which fixed it.

Similar Threads

  1. Company Phone Message Voiceovers Please
    By MarcAlle in forum Request A Free Voiceover
    Replies: 11
    Last Post: 11-16-2009, 10:10 AM
  2. What is the minimal equipment for voice overs?
    By JBVoice in forum Audio Production
    Replies: 3
    Last Post: 10-10-2009, 11:18 PM
  3. What player do you use to listen
    By teltek in forum General Internet Radio Discussions
    Replies: 11
    Last Post: 04-15-2009, 03:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •