Jump to content

Shoutcast2 (altacast fb2k) not showing titles


Recommended Posts

Hello i use shoutcast v1 for years i changed to v2 last month, but i can still not see any title updates in the shoutcast directory.

it only shows titles with the player, not on the dir.

Someone know whats wrong.

the shoutcast server runs on linux.

Link to comment
Share on other sites

You need to set the Autohash for SHOUTcast version 2, or your station will not get listed. Directions are in the Documentation files that came with SC2.

SCS - Dedicated Bandwidth Servers

Shoutcast / Icecast / Windows Media

Transcoding - Auto DJ - Mobile Radio - FLASH Players - Auto DJ

Broadcasting World's Stream Host of the Month

Link to comment
Share on other sites

Apply the appropriate ending to your page call:

[b]currentsong?sid=#[/b]  -  Returns the current song title or a null response 
[b]nextsong?sid=#[/b]  -  Returns the next song title (if known) or a null response 

currentsong and nextsong both provide a UTF-8 encoded string of the song title otherwise it will return effectively no response (ignoring the http header).  [b]nextsongs?sid=#[/b]  -  Returns in an xml format the next song title(s) (if known) to be played when using a compatible v2 stream source. See [url="http://wiki.winamp.com/wiki/SHOUTcast_DNAS_Server_2#XML_Responses"]section 5.2[/url] for more details on the format of the xml returned). 

[b]index.html?sid=#[/b]  -  Shows current status of the specified stream 

[b]played.html?sid=#[/b]  -  Song history of specified playing history 

So, for example, if I want to see what the current song title is:




Which will return the current song playing on mountpoint #1 of my shoutcast server running on port 8000.


To view the song history:




If I understand your question correctly...

Link to comment
Share on other sites

i added the hash months ago, so the station appears to the directory, i tried to update the hash tag and had an weirdo error

Error Code: 459.

"Authhash could not be found for reading"

something is borked



Link to comment
Share on other sites

Thank you, it does not work, i think its a bug in the sc_serv software


2013-05-19 12:42:58 I msg:[DST sid=1] SHOUTcast 1 client connection accepted. SHOUTcast Metadata Puller2013-05-19 12:42:58 E msg:[DST sid=1] Socket error while waiting to send data. err=Connection reset by peer(104)

Link to comment
Share on other sites

Is either:


1- Your home PC ?


2- A VPS ?


If so, make sure that port 59158 is not blocked by your firewall.


yes Port is open, i can send you the config file.

but you need to pm me first because im unable to send pm with

I use a FIOS connection with 100MBit synchronous, on a Linux Server direct connected, no firewall, only some iptable rules to block a few "dangerous" ports like 135 and NFS ports.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...