Jump to content

Music echoes/feedback when mic is on - SAM BC


Recommended Posts

Hi

 

When I turn the mic on(lock) in SAM, the music echoes, but vocals are fine. I'm pretty much stumped

 

The equipment was last used to broadcast and worked fine

 

My setup:

XP SP3

Sam Broadcaster 4.9.0

External Soundcard E-MU

 

In SAM >

Audio Pipiline>

Voice FX destination is Encoders

 

VoiceFX config>

destination - Encoders(rec to pipeline, skip output)

 

Sorry I'm not very clear on the problem, I'm new to all this

 

Thanks in advance for any advice

Link to comment
Share on other sites

Your audio has a pipeline in sam, that has various setups for the mic.

 

If your audio pipeline isnt configured right, it will pull the audio from 2 sources. 1 from the live audio source, and then one from a mix of audio and your voice. Make sure your not using stereo out/what you hear as your audio mic source. this will cause THE EXACT issue your having on the pipeline.

 

Basiclly, it pulls the live audio, and mixes it with the live audio/your voice, which gets looped in the stereo mix back into the audio pipeline, and echos, all with a little latency to make you crazy.

KNSJ.org / 89.1 FM San Diego
Link to comment
Share on other sites

Many thanks for the replies

 

@PapaBearBW - There's no audible audio coming out, I've got a monitor but audio not being fed back in as testing with it off, just using cans. Tried it with SAM muted and still the same :/

 

@Brutish Sailor - I've got a feeling you've hit the nail on the head but trying to decipher where I'm going wrong, given this setup is more or less the same as when it was a working station,however I've reinstalled audio drivers. I'm unclear what and where I should be tweaking though. I have a couple of former working backups of the digital mixer I've restored but still no joy. I've tried encoding in Mono and the other options too

Link to comment
Share on other sites

Also, are you using a mixer, or just a mic with a connection? Just to eliminate some stuff out of the equation.

 

Its not your audio drivers. Its the source settings in your comp itself.

 

You need to get to "recording" settings, and set your mic to what it is.

 

Then you need to verify SAM has Identified this hardwares source "X soundcard line in/,.......

 

 

 

Edit: I saw from your post, your using a mixer...... This might be your problem. You need to set Sam to designate the sounds on different channels. Bypass the audio on press to talk.

 

Here could possibly be your echo:

 

 

Soundcard line out-----> mixer channel------> Audio with the mixer channel and your voice------> line out-------> Sound processed on an audio channel with sound card------> sound back to the mixer.

Edited by Brutish Sailor
KNSJ.org / 89.1 FM San Diego
Link to comment
Share on other sites

Let me start over.

 

Ok, so what you got going on is a mixer, which your trying to monitor the audio while you play, and then fade your mic in and out correct?

 

Can you hit "print screen" and paste the output into MS paint, then upload the image?

Edited by Brutish Sailor
KNSJ.org / 89.1 FM San Diego
Link to comment
Share on other sites

Arghhh, I'm getting to go all rock and roll on this kit

 

With external mixer switched off, problem still exists

 

PatchMix DSP mixer settings are from working backups, see attached image

 

Now here's something weird(to me anyway), in SAM If I change encoders to the record button rather than DSP, the echo goes, everything sounds perfect but the mic's are permanently live, but fades normal when pressing mic - talk

 

Beam me up!

emu mixer.jpg

Link to comment
Share on other sites

  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...